Dolphin, problèmes Super Mario Galaxy 2- Forum

Index du forum > Wii > Hack de la Wii

Topic: Dolphin, problèmes Super Mario Galaxy 2

par Déconnecté Mebenn le 22/11/11 à 23:45:29 (il y a 5 ans 1 semaine 5 jours 3 heures 46 minutes) 12 réponses, vu 7875 fois
Bonsoir à tous,

Voilà, je joue à Super mario galaxy 2 depuis quelques jours et deux problèmes sont survenus récemment.
Bon, déjà je pense qu'ils ne sont pas liés.

Le premier, le moins embêtant, est la disparition de la musique au bout d'une certain temps. Pas des sons, simplement la musique de fond.
En fait elle ne fait pas de boucle. Les musiques sont programmées pour qu'une fois la boucle terminée ça recommence, hors ici ça ne le fais. La musique joue pendant un certain et au moment où elle doit redémarrer, elle disparaît, tout bonnement.

C'est pas très embêtant, mais je trouve ça dommage car les musiques des Super Mario Galaxy sont simplement magnifiques.

2ème problème, plus embêtant.
Je jouais tranquillement, là j'arrive au dernier niveau du 1er monde, celui avec le dragon qui à des problèmes digestifs... à la fin du niveau, je récupère la grande étoile et là, écran noir.
L'écran amorce la transition comme pour revenir sur le vaisseau Mario, mais l'écran reste noir.
Aucun message d'erreur, mais je continu quand même à entendre des sons, des espèces de "bloub", un bruit bizarre dans le style.
Ce bug était déjà survenu hier, alors je pensais que c'était un crash du jeu.
Aujourd'hui je refais le niveau comme j'avais pas fait de save, juste avant de prendre l'étoile, je fais une statesave, et là même bug. Même en revenant sur la statesave après avoir redémarrer Dolphin.

Voilà, j'espère que vous aurez une solution à me proposer.

Merci d'avance.

Dernière édition le 22/11/11 à 23:45:54 par Mebenn.
 



Pages: 1
Messages:
^ Déconnecté zeripou
#1, posté le 22/11/11 à 23:52:56
Membre
1120 messages
Dieu
star
avatar
Une autre sauvegarde (refais la) règlera peut être le problème, sinon je sèche. Je regarderai quand même (si j'étais toi) au cas ou quelqu'un d'autre aurait le même problème, et éventuellement la solution0 Mais ce genre de bug proviennent en général, soit d'une mauvaise sauvegarde, soit d'une mauvaise configuration.
Y'en a_t_il (de configuration) une en particulier pour ce jeu?
iPhone info, tout le hack, jailbreak, désimlock iPhone iPad iPod
^ Déconnecté Attila
#2, posté le 23/11/11 à 15:44:15
Administrateur
23117 messages
Dieu des dieux
starstarstarstarstarstar
avatar
tu a quelle version de dolphin? la version "stable" ou svn ?
^ Déconnecté panda64
#3, posté le 26/11/11 à 06:32:34
Membre
38 messages
Débutant
star
c'est normal que la musique part au bout de 2 minutes , il reste que les bruitages:;)::

car tu as le son réglé en dspHLE, tu dois le regler en dspLLE ::^^::
et tu aura la musique complete du jeux de A a Z
j'ai fini le jeux sur dophin 3.0 r201 et aucun soucis::)::

par contre le LLE demande un gros processeur bien + que le dspHLE pour pas ramé::wtf::
c'est la même histoire avec mario galaxy 2

dspHLE = bon son en genéral mais a encore des bugs, demande moins de ressources de le LLE
dspLLE = son a la perfection mais demande un processeur très rapide!!

Dernière édition le 26/11/11 à 06:40:56 par panda64.
^ Déconnecté Mebenn
#4, posté le 08/12/11 à 02:05:14
Membre
5 messages
Petit nouveau
star
un peu de retard...

Merci Panda64, néanmoins impossible de lancer le jeu en LLE.
Mon procésseur est assez récent et devrait faire l'affaire, peut être y a-t-il une configuration spéciale pour jouer en LLE à effectuer ?

Quand je lance, que ce soit en "Recompilateur du DSP en LLE" ou "Interpréteur du DSP en LLE"
j'ai plusieurs messages d'erreurs :

"Impossible de lire la ROM du DPS ./User/GC/dps_rom.bin
Ce fichier est requis pour utiiliser DPS LLE
Il n'est pas fourni avec dolphin..."

"Failed to initialize DPS emulator"

Je suppose que ça vient du manque de ce fichier. Quel est la manipulation à faire pour l'obtenir ?

Dernière édition le 08/12/11 à 02:08:29 par Mebenn.
^ Déconnecté Attila
#5, posté le 09/12/11 à 09:28:45
Administrateur
23117 messages
Dieu des dieux
starstarstarstarstarstar
avatar
utiliser google :)
^ Déconnecté Mebenn
#6, posté le 09/12/11 à 14:19:22
Membre
5 messages
Petit nouveau
star
Oui, donc j'ai réussis à trouver les fichiers manquants. Seulement le son est extrêmement saccadé, pourtant mon processeur est très récent et tourne à plus de 3GHz en mode turbo.

Y a-t-il une configuration optimale à effectuer sur le panneau de contrôle du son ?

EDIT :
Bon j'ai eu quelques infos, le recompilateur en LLE fonctionne sans retard (sans lag et sans saccade) seulement quand le jeu tourne à 100%.
En gros pour avoir un bon son, il faut avoir une config extrêmement puissante qui puisse émuler continuellement du 100% !
Panda64, tu dois avoir une bête pour ne pas avoir rencontrer de problème avec le LLE !

Dernière édition le 09/12/11 à 23:11:14 par Mebenn.
^ Déconnecté ricci42
#7, posté le 27/12/11 à 15:53:17
Membre
3 messages
Petit nouveau
star
Du coup, pour ce problème de blocage après la première grande étoile, vous l'avez résolu?
Car moi je viens de l'avoir, au même endroit.
Es-ce la ROM qui est défectueuse?
Une mauvaise config de Dolphin?
Je suis en 3.0 204

Merci par avance
Ric
^ Déconnecté iFearFactor
#8, posté le 27/12/11 à 15:59:00
Membre
3393 messages
Dieu des dieux
star
avatar
Bonjour,

Refaits ton dump de jeu et réessayes.
^ Déconnecté ricci42
#9, posté le 27/12/11 à 18:05:49
Membre
3 messages
Petit nouveau
star
J'ai eu ce soucis avec un dump effectivement, du coup, j'ai relancé le jeu sans charger de dump, charger la sauvegarde classique du jeu par l'interface du jeu, refait le niveau du premier boss, et quand je le tue, et que je récupère la première grande étoile, j'ai le même résultat.
Cela ne vient donc pas du dump...
C'est pourquoi j'ai posté ici, Mebenn qui a le même problème que moi au même endroit exactement, je me dit que soit une config fout la merde, genre une cinématique qui ne peut pas être lue dans cette config, soit c'est l'image ISO qui est corrompue...
Donc, si vous avez d'autres idées, ou si Mebenn a trouvé une solution...

Merci
^ Déconnecté iFearFactor
#10, posté le 27/12/11 à 18:14:23
Membre
3393 messages
Dieu des dieux
star
avatar
Framework dernière version est bien installé chez vous ?
^ Déconnecté ricci42
#11, posté le 27/12/11 à 18:20:17
Membre
3 messages
Petit nouveau
star
J'ai dolphin 3.0-204-dirty d'installer si c est de ca que vous parlez (je joue sur pc et pas sur console)

Sinon, j'ai trouvé également cela sur un un autre site pour ce jeu :

DSP Settings

Audio Backend: OpenAL - only use this before getting first (and maybe others) Grand Star + turn all audio in Dolphin settings off

Est ce que c est le fait d avoir le son en HLE qui provoquerait un problème, faut il que je change quelque chose? En plus je ne peux pas passer en LLE, et si je coupe toutes les options pour le son, ca ne passe pas quand même...

EDIT : c'est bien ca, pb sur ce jeu, il faut passer en LLE au moment de l etoile. J'ai donc "patché" dolphin en mettant 2 fichiers dsp, qui ne me donnent pas de son, mais avec, cela fonctionne, ensuite on enregistre, et on renlève ces fichiers.

Dernière édition le 27/12/11 à 19:32:32 par ricci42.
LOLTube.fr - Humour image
^ Déconnecté AARONJACOBFLIT
#12, posté le 23/05/13 à 16:07:26
Membre
1 messages
Petit nouveau
star
Bonjour à tous !
Vos messages datent un peu mais ayant eu exactement le même problème et ayant trouvé la solution, si d'autres personnes se trouvent dans l'embarras ce post aidera sûrement ! ::^^::

Le soucis de la Musique qui STOP au moment de la boucle touche certains jeux, tel Mario Galaxy 1 et 2, Mario Kart Double Dash et certainement d'autres. Le problème ne vient pas de Dolphin, mais de la carte son du PC. Il faut tout simplement brancher un câble HDMI à la place du câble DVI. Le bug est immédiatement résolu. Egalement éviter de brancher un casque directement sur la carte son.

Concernant la fin du Boss du premier niveau de Mario Galaxy 2, il suffit de couper le son dans Dolphin : paramètre de l'interface audio, NO AUDIO INPUT. Refaite le niveau, normalement pas de bug, le jeu enchaîne la cinématique, sauvegarder, puis reset et reconfiguration du son à son paramètre d'origine :;)::

Bon jeu les gars ^^

Dernière édition le 24/05/13 à 06:04:49 par AARONJACOBFLIT.

Pages: 1

Ajouter commentaire:
Créez un compte ou identifiez vous pour poster un commentaire.

Index du forum > Wii > Hack de la Wii


Pour votre téléphone, Jailbreak iPhone et Jailbreak iPad. - Hack PS3 - Hacker sa WiiU - Hacker PS Vita - Rage Comics, troll face - Retrouvez chaque jour des image drole sur internet grâce à LOLTube. - Meme Internet
596 connectés (2 membres, 594 anonymes)© 2007-2015 Attila